Get in touch
Back
Resolved

DNS Problems.

Started 8 Feb at 06:17am WIB.

api.pakai.eu.org f-api.pakai.eu.org
Created

All domain from freenom get pending status and affected to dns.

Posted 8 Feb at 06:17am WIB.